EMP platform unavailable

Incident Report for Equativ Monetization

Resolved

This incident has been Resolved
Posted Jul 28, 2025 - 15:38 CEST

Investigating

Dear Customer,
EMP platform is currently unavailable. We are working actively to resolve it, we appreciate your patience and understanding.
Thanks.
#INC-1332
Posted Jul 28, 2025 - 15:25 CEST
This incident affected: EMP UI.