Service disruption on APAC

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.
Posted May 18, 2026 - 09:03 UTC

Monitoring

Dear Customer,

You may have experienced increased response times in the APAC region today May 18th between 6.35 AM and 7.25 AM UTC
Our technical team has implemented corrective actions and is currently monitoring the situation closely to ensure service stability.

We apologize for any inconvenience caused.

#inc-1522
Posted May 18, 2026 - 07:59 UTC
This incident affected: Delivery EMEA / APAC.