Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2025 - 08:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 06, 2025 - 11:42 CEST
Scheduled
Dear Customer,
To improve our services, maintenance is scheduled as follows:
Start time: 12/08/2025, 06:00 UTC End time: 12/08/2025, 08:00 UTC
During this time, Maestro Activation Bidding activity may be lower than usual in the US, EU and APAC region. Access to the Maestro UI will remain fully available.