Possible bids drop on Activation Module

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 14:31 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 13:54 CEST

Investigating

Dear customer,

You may experience a decrease of bids for campaigns created in the Activation module in Maestro since 08/29.

Our technical teams are investigating the root cause.

We apologize for the inconvenience.

#1352
Posted Sep 02, 2025 - 11:26 CEST
This incident affected: Activation.