Latency and timeout on SSB integration for Americas

Incident Report for Equativ Monetization

Resolved

Dear Customer,

We have identified and mitigated the issue.

Start Date & Time: 28 May 2026, 20:45 UTC
End Date & Time: 28 May 2026, 21:45 UTC

Total duration of the incident: 1 hour.

We apologize for the inconvenience caused.

#INC-1541
Posted May 28, 2026 - 22:04 UTC

Identified

Dear Customer,

Some timeouts and statistics latencies may be noticeable for our Americas clients.

Our team is currently working on a fix. We will let you know as soon as we have more updates.

We apologize for the inconvenience and will provide updates as more information becomes available.

#INC-1541
Posted May 28, 2026 - 21:29 UTC
This incident affected: Delivery US.