Creation/update for deal and line item failed

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 17:46 CEST

Investigating

Dear customer,

We experienced an incident where deals and line items couldn't be created or updated in Maestro. Issue happened from 16h30 to 16h55 UTC and is now fixed.
Posted Jul 24, 2025 - 17:46 CEST
This incident affected: Maestro UI.