SSB Delivery Disruption in the US East Region

Incident Report for Equativ Monetization

Resolved

Dear Customer,

Thank you for your patience during this time.

Our technical team has resolved the SSB delivery issue on US delivery.
Start time of the incident: August 17th, 9:00 AM UTC
End time of the incident: August 17th, 10:00 AM UTC

Apologize for the inconvenience caused.

#inc-1592
Posted Aug 18, 2026 - 07:56 UTC

Identified

Dear Customer,

SSB delivery may have experienced disruptions on August 17 between 9:00 AM and 10:00 AM UTC.

Our technical team is currently investigating the issue and working to identify the root cause.

We apologize for any inconvenience this may have caused and will provide further updates as soon as they become available.

#inc-1592
Posted Aug 17, 2026 - 12:53 UTC
This incident affected: Delivery US.