Inacuracy of clicks on Instant Insights

Incident Report for Equativ Monetization

Resolved

Dear customer,

Clicks inaccuracy at instant insights, showing up to 3x more volume, is now fixed.

We appreciate the patience.

#INC-1324
Posted Jul 21, 2025 - 17:27 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 18, 2025 - 00:10 CEST

Identified

Dear customer,

Clicks data for Activation Module is inaccurate at instant insights, showing up to 3x more volume. Issues has been identified and a fix is in place.

We apologize for the inconvenience.

#INC-1324
Posted Jul 17, 2025 - 22:20 CEST
This incident affected: Maestro UI and Activation.