EMP platform instability

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.

#INC-1490
Posted Apr 15, 2026 - 14:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 13:08 UTC

Identified

Dear customers,

Due to an issue on our side, you may notice a drop of delivery, a decline in revenue or increased latency in the EU from Apr 15, 2026, 9:00 AM UTC. Technically, the issue has been resolved in the EU since 1:30 p.m. UTC. However, it is currently affecting the U.S. (Western) region.
We're working on it so we can resolve the issue as soon as possible.

We apologize for the inconvenience, and thank you for your patience.

#INC-1490
Posted Apr 15, 2026 - 13:08 UTC
This incident affected: EMP UI.