Deals List Loading Issue on Maestro Platform

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 15:10 CEST

Identified

Dear Customer,
You may be experiencing difficulties with accessing the deals list on the Maestro platform. Please be assured that our team is actively working to resolve this issue as quickly as possible.
We apologize for any inconvenience this may cause and sincerely appreciate your patience and understanding.
#1357
Posted Sep 08, 2025 - 11:56 CEST