Bid Request Latency Americas region

Incident Report for Equativ Monetization

Resolved

Dear Customers,

The earlier latency affecting bid requests, impacting SSB and Classic RTB insertion integrations, has now fully recovered. Client-side integrations remained unaffected throughout the incident.

Incident timeframe: from 17:38 UTC to 22:45 UTC on December 1st.

Our engineering team has implemented the necessary fixes, and all systems are operating normally.

This incident is now considered resolved.

Thank you for your patience.

#INC-1425
Posted Dec 01, 2025 - 23:39 CET

Update

Dear Customers,

We have identified that the latency issue is affecting SSB and Classic RTB insertion integrations.
At this time, Client-Side integrations remain unaffected.

Our engineering team continues to work on mitigation, and improvements are ongoing.
We will share additional updates as soon as more information becomes available.

#INC-1425
Posted Dec 01, 2025 - 22:43 CET

Identified

Dear Customers,

We are currently experiencing increased latency on bid requests, which is impacting bid win volume.
The issue began at approximately 18:38 UTC.

Our engineering team is actively working on mitigation, and we are already seeing signs of improvement.

We will provide further updates as soon as more information becomes available.

#INC-1425
Posted Dec 01, 2025 - 22:23 CET
This incident affected: Delivery US.