Reporting - RTB Data Latency

Incident Report for Equativ Monetization

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 10:59 CET

Identified

Dear Customers,

We have identified reporting issue where we observe RTB Data Latency. Our team is working on to fix this as soon as possible.

Start date & time: November 20th, 2025, at 2:07 PM UTC

We apologize for the inconvenience caused. Thank you for your patience.

#inc-1417
Posted Nov 20, 2025 - 15:34 CET
This incident affected: Reporting.